aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-24 13:53:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-24 17:40:41 +0300
commit200405c49050655282968faea3e5d09f97fbd5df (patch)
tree66511e0162435ab407c5e9bebe457b73ebd372a5
parent9f310ab6caf52c135584bdbb2ca0cb819aa6423e (diff)
downloadguix-200405c49050655282968faea3e5d09f97fbd5df.tar
guix-200405c49050655282968faea3e5d09f97fbd5df.tar.gz
gnu: Remove rust-shell2batch-0.4.
* gnu/packages/crates-io.scm (rust-shell2batch-0.4): Delete variable. * gnu/packages/patches/rust-shell2batch-lint-fix.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/crates-io.scm24
-rw-r--r--gnu/packages/patches/rust-shell2batch-lint-fix.patch25
3 files changed, 0 insertions, 50 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index c325e6984b..48df2eb1a3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1814,7 +1814,6 @@ dist_patch_DATA = \
%D%/packages/patches/rust-nettle-disable-vendor.patch \
%D%/packages/patches/rust-nettle-sys-disable-vendor.patch \
%D%/packages/patches/rust-openssl-sys-no-vendor.patch \
- %D%/packages/patches/rust-shell2batch-lint-fix.patch \
%D%/packages/patches/rust-wl-clipboard-rs-newer-wl.patch \
%D%/packages/patches/sbc-fix-build-non-x86.patch \
%D%/packages/patches/sbcl-aserve-add-HTML-5-elements.patch \
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8a354fe0a7..4e17efdf16 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -69115,30 +69115,6 @@ Rust.")
including a line breaking iterator.")
(license license:asl2.0)))
-(define-public rust-shell2batch-0.4
- (package
- (name "rust-shell2batch")
- (version "0.4.2")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "shell2batch" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0r9zfhxmqnrnyk7g590333szfpsjijs2wfwy7ish240w6pp54nhq"))
- ;; https://github.com/sagiegurari/shell2batch/issues/17
- (patches (search-patches "rust-shell2batch-lint-fix.patch"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs (("rust-regex" ,rust-regex-1))))
- (home-page "https://github.com/sagiegurari/shell2batch")
- (synopsis "Basic shell scripts to windows batch scripts conversion")
- (description "While it is not really possible to take every shell script
-and automatically convert it to a windows batch file, this library provides a
-way to convert simple shell commands to windows batch commands.")
- (license license:asl2.0)))
-
(define-public rust-enquote-1
(package
(name "rust-enquote")
diff --git a/gnu/packages/patches/rust-shell2batch-lint-fix.patch b/gnu/packages/patches/rust-shell2batch-lint-fix.patch
deleted file mode 100644
index 7c160b6cca..0000000000
--- a/gnu/packages/patches/rust-shell2batch-lint-fix.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Resolves the following error that was most likely introduced in new version of
-rust as this package is from 2019:
-
-error: unnecessary parentheses around type
- --> src/converter.rs:108:61
- |
-108 | fn add_arguments(arguments: &str, additional_arguments: Vec<(String)>, pre: bool) -> String {
- | ^^^^^^^^ help: remove these parentheses
-
-Reported upstream at https://github.com/sagiegurari/shell2batch/issues/17.
-
-diff --git a/src/converter.rs b/src/converter.rs
-index fc87d68..af309d2 100644
---- a/src/converter.rs
-+++ b/src/converter.rs
-@@ -105,7 +105,7 @@ fn replace_vars(arguments: &str) -> String {
- updated_arguments
- }
-
--fn add_arguments(arguments: &str, additional_arguments: Vec<(String)>, pre: bool) -> String {
-+fn add_arguments(arguments: &str, additional_arguments: Vec<String>, pre: bool) -> String {
- let mut windows_arguments = if pre {
- "".to_string()
- } else {
-