aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-24 13:56:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-24 17:40:42 +0300
commit09962d54c1c18c8893631613a3c84e910b98d968 (patch)
treec3c5123b9d63a2dcc3c397afc59f7ba678edffc0
parent200405c49050655282968faea3e5d09f97fbd5df (diff)
downloadguix-09962d54c1c18c8893631613a3c84e910b98d968.tar
guix-09962d54c1c18c8893631613a3c84e910b98d968.tar.gz
gnu: rust-cargo-edit-0.8: Move to rust-apps.scm.
* gnu/packages/crates-io.scm (rust-cargo-edit-0.8): Move to ... * gnu/packages/rust-apps.scm (rust-cargo-edit-0.8): ... here.
-rw-r--r--gnu/packages/crates-io.scm49
-rw-r--r--gnu/packages/rust-apps.scm51
2 files changed, 50 insertions, 50 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4e17efdf16..0e6ed24955 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9344,55 +9344,6 @@ capabilities.")
the library crate of Cargo.")
(license (list license:expat license:asl2.0))))
-(define-public rust-cargo-edit-0.8
- (package
- (name "rust-cargo-edit")
- (version "0.8.0")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "cargo-edit" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0yk5f4qjzflfqzgfws9zifij2fqchc9q551m7ljznmjrhlif2yh4"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-atty" ,rust-atty-0.2)
- ("rust-error-chain" ,rust-error-chain-0.12)
- ("rust-git2" ,rust-git2-0.13)
- ("rust-hex" ,rust-hex-0.4)
- ("rust-regex" ,rust-regex-1)
- ("rust-semver" ,rust-semver-1)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-derive" ,rust-serde-derive-1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-termcolor" ,rust-termcolor-1)
- ("rust-toml-edit" ,rust-toml-edit-0.3)
- ("rust-url" ,rust-url-2)
- ("rust-crates-index" ,rust-crates-index-0.17)
- ("rust-cargo-metadata" ,rust-cargo-metadata-0.14)
- ("rust-dirs-next" ,rust-dirs-next-2)
- ("rust-dunce" ,rust-dunce-1)
- ("rust-env-proxy" ,rust-env-proxy-0.4)
- ("rust-pathdiff" ,rust-pathdiff-0.2)
- ("rust-structopt" ,rust-structopt-0.3)
- ("rust-subprocess" ,rust-subprocess-0.2)
- ("rust-toml-edit" ,rust-toml-edit-0.3)
- ("rust-ureq" ,rust-ureq-1))
- #:cargo-development-inputs
- (("rust-assert-cmd" ,rust-assert-cmd-2)
- ("rust-assert-fs" ,rust-assert-fs-1)
- ("rust-predicates" ,rust-predicates-2)
- ("rust-pretty-assertions" ,rust-pretty-assertions-0.6))))
- (home-page "https://github.com/killercup/cargo-edit")
- (synopsis "Add and remove dependencies from the command line")
- (description
- "This package extends Cargo to allow you to add and remove dependencies
-by modifying your @file{Cargo.toml} file from the command line.")
- (license (list license:asl2.0 license:expat))))
-
(define-public rust-cargo-metadata-0.14
(package
(name "rust-cargo-metadata")
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index cdd01ad68b..d4f4413b07 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2021, 2022 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
@@ -890,6 +890,55 @@ browsers.")
(define-deprecated rust-swc-1 rust-swc)
+(define-public rust-cargo-edit-0.8
+ (package
+ (name "rust-cargo-edit")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "cargo-edit" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0yk5f4qjzflfqzgfws9zifij2fqchc9q551m7ljznmjrhlif2yh4"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-atty" ,rust-atty-0.2)
+ ("rust-error-chain" ,rust-error-chain-0.12)
+ ("rust-git2" ,rust-git2-0.13)
+ ("rust-hex" ,rust-hex-0.4)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-semver" ,rust-semver-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-termcolor" ,rust-termcolor-1)
+ ("rust-toml-edit" ,rust-toml-edit-0.3)
+ ("rust-url" ,rust-url-2)
+ ("rust-crates-index" ,rust-crates-index-0.17)
+ ("rust-cargo-metadata" ,rust-cargo-metadata-0.14)
+ ("rust-dirs-next" ,rust-dirs-next-2)
+ ("rust-dunce" ,rust-dunce-1)
+ ("rust-env-proxy" ,rust-env-proxy-0.4)
+ ("rust-pathdiff" ,rust-pathdiff-0.2)
+ ("rust-structopt" ,rust-structopt-0.3)
+ ("rust-subprocess" ,rust-subprocess-0.2)
+ ("rust-toml-edit" ,rust-toml-edit-0.3)
+ ("rust-ureq" ,rust-ureq-1))
+ #:cargo-development-inputs
+ (("rust-assert-cmd" ,rust-assert-cmd-2)
+ ("rust-assert-fs" ,rust-assert-fs-1)
+ ("rust-predicates" ,rust-predicates-2)
+ ("rust-pretty-assertions" ,rust-pretty-assertions-0.6))))
+ (home-page "https://github.com/killercup/cargo-edit")
+ (synopsis "Add and remove dependencies from the command line")
+ (description
+ "This package extends Cargo to allow you to add and remove dependencies
+by modifying your @file{Cargo.toml} file from the command line.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public git-interactive-rebase-tool
(package
(name "git-interactive-rebase-tool")