aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2021-04-08 11:13:11 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2021-04-08 11:18:06 +0100
commit71ca8fd40b05cd0da14fad2e4b67f8d480abe600 (patch)
tree6f12e154bbae75aa37d46c03287a98e69fde2493
parentbb4f47a7f614eea78a8c8a0d3e5fc55bf4e52646 (diff)
downloadguix-71ca8fd40b05cd0da14fad2e4b67f8d480abe600.tar
guix-71ca8fd40b05cd0da14fad2e4b67f8d480abe600.tar.gz
gnu: Add texlive-mweights.
* gnu/packages/tex.scm: New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c8bac7eea7..df84cbd571 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7928,3 +7928,23 @@ particular, it splits the shape axis into a primary and a secondary
shape axis and it adds three new axes to deal with the different
figure versions offered by many professional fonts.")
(license license:lppl1.3+)))
+
+(define-public texlive-mweights
+ (package
+ (inherit (simple-texlive-package
+ "texlive-mweights"
+ (list "/doc/latex/mweights/"
+ "/tex/latex/mweights/")
+ (base32
+ "1k2xclk54q3xgn48hji23q52nivkzgwf0s30bmm6k83f7v57qv8h")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/mweights")
+ (synopsis "Support for multiple-weight font packages")
+ (description "Many font families available for use with LaTeX are
+available at multiple weights. Many Type 1-oriented support packages
+for such fonts re-define the standard @code{\\mddefault} or
+@code{\\bfdefault} macros. This can create difficulties if the weight
+desired for one font family is not available for another font family,
+or if it differs from the weight desired for another font family. The
+@code{mweights} package provides a solution to these difficulties.")
+ (license license:lppl)))