aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormethuselah-0 <david.larsson@selfhosted.xyz>2021-03-31 12:38:50 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-08 23:28:01 +0200
commit43c55856c876c76200cdccc1211868b92352c4ae (patch)
treea4d20ddda41ca6be838783ae5c585556f3e76a45
parent06eb21856f9535ab62d0becc92b4146e0620654e (diff)
downloadguix-43c55856c876c76200cdccc1211868b92352c4ae.tar
guix-43c55856c876c76200cdccc1211868b92352c4ae.tar.gz
gnu: Add galera.
* gnu/packages/databases.scm (galera): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/databases.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ce7afa82d0..8c657e4113 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1002,6 +1003,31 @@ as a drop-in replacement of MySQL.")
developed in C/C++ to MariaDB and MySQL databases.")
(license license:lgpl2.1+)))
+(define-public galera
+ (package
+ (name "galera")
+ (version "26.4.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit "bac8171266cb982fe013ce496d78085438c6f23e")
+ (url "https://github.com/codership/galera")
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h7s670pcasq8wzprhyxqfca2cghi62b8xz2kikb2a86wd453qil"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("check" ,check)
+ ("boost" ,boost)
+ ("openssl" ,openssl)))
+ (home-page "https://github.com/codership/galera/")
+ (synopsis "Extension to the MariaDB database server")
+ (description
+ "Galera is a wsrep-provider that is used with MariaDB for load-balancing
+and high-availability (HA).")
+ (license license:gpl2))) ;'COPYING' says "version 2" only
+
;; Don't forget to update the other postgresql packages when upgrading this one.
(define-public postgresql-13
(package