aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-02 22:02:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-02 22:02:23 +0100
commitdffc918af6cf6e1ce942dd329d210271ced1205d (patch)
treea291cc94667808b6ecd7d2847954674ceab2b697
parent4532a1575b8159054c90d3f16ca60d9b61777c25 (diff)
downloadguix-dffc918af6cf6e1ce942dd329d210271ced1205d.tar
guix-dffc918af6cf6e1ce942dd329d210271ced1205d.tar.gz
gnu: Add beets-next.
* gnu/packages/music.scm (beets-next): New variable.
-rw-r--r--gnu/packages/music.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4c1681f2a4..1193c83a13 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3484,6 +3484,59 @@ websites such as Libre.fm.")
of tools for manipulating and accessing your music.")
(license license:expat)))
+(define-public beets-next
+ (let ((commit "04ea754d00e2873ae9aa2d9e07c5cefd790eaee2")
+ (revision "1"))
+ (package
+ (inherit beets)
+ (name "beets-next")
+ (version (git-version (package-version beets) revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/beetbox/beets")
+ (commit commit)))
+ (sha256
+ (base32
+ "092a9sss2shhcjmpgbwvscv8brpm5970i5hddkhi81xcff3bg1h4"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; XXX: unclear why this fails
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "test/test_zero.py"
+ (("def test_album_art") "def _test_album_art"))
+ #t))
+ (add-after 'unpack 'set-HOME
+ (lambda _
+ (setenv "HOME" (string-append (getcwd) "/tmp"))
+ #t))
+ (replace 'check
+ (lambda _
+ ;; Resources must be writable.
+ (for-each make-file-writable
+ (find-files "test/rsrc" "."))
+ (invoke "nosetests" "-v")))
+ ;; Wrap the executable, so it can find python-gi (aka pygobject) and
+ ;; gstreamer plugins.
+ (add-after 'wrap 'wrap-typelib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/beet"))
+ (plugins (getenv "GST_PLUGIN_SYSTEM_PATH"))
+ (types (getenv "GI_TYPELIB_PATH")))
+ (wrap-program prog
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,plugins))
+ `("GI_TYPELIB_PATH" ":" prefix (,types)))
+ #t))))))
+ (inputs
+ `(("python-confuse" ,python-confuse)
+ ("python-mediafile" ,python-mediafile)
+ ("python-reflink" ,python-reflink)
+ ("python-requests-oauthlib" ,python-requests-oauthlib)
+ ,@(package-inputs beets))))))
+
(define-public beets-bandcamp
(package
(name "beets-bandcamp")