aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Côté <antoine.cote@posteo.net>2021-02-02 15:38:02 -0500
committerTobias Geerinckx-Rice <me@tobias.gr>2021-02-02 22:55:01 +0100
commitd65a25c9a2fdc9940c691afd8a10c7d489052cdf (patch)
tree143072a7cf1a22d363d35c9050583d5d26da7981
parentc1e7ae444a77aa5cc78a715f78843ccd178c9d6b (diff)
downloadguix-d65a25c9a2fdc9940c691afd8a10c7d489052cdf.tar
guix-d65a25c9a2fdc9940c691afd8a10c7d489052cdf.tar.gz
gnu: Add font-space-grotesk.
* gnu/packages/fonts.scm (font-space-grotesk): New variable. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/fonts.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index b3a45a0df2..92a7580cf6 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1393,6 +1393,43 @@ programming. Iosevka is completely generated from its source code.")
"Sarasa Gothic is a programming font based on Iosevka and Source Han Sans,
most CJK characters are same height, and double width as ASCII characters.")))
+(define-public font-space-grotesk
+ (package
+ (name "font-space-grotesk")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/floriankarsten/space-grotesk")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1aiivn0rl7ydiyqvsr0fa2hx82h3br3x48w3100fcly23n0fdcby"))))
+ (build-system font-build-system)
+ ;; TODO: Package fontmake and gftools and build from source.
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'install-license-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (install-file "OFL.txt" doc)
+ #t))))))
+ (home-page "https://floriankarsten.github.io/space-grotesk/")
+ (synopsis "Proportional variant of the fixed-width Space Mono family")
+ (description
+ "Space Grotesk is a proportional sans-serif typeface variant based on Colophon
+Foundry's fixed-width Space Mono family. It retains the monospace's idiosyncratic
+details while optimizing for improved readability at non-display sizes.
+
+Space Grotesk includes Latin Vietnamese, Pinyin, and all Western, Central, and
+South-Eastern European language support, as well as several OpenType features:
+old-style and tabular figures, superscript and subscript numerals, fractions,
+and stylistic alternates.")
+ (license license:silofl1.1)))
+
(define-public font-go
(let ((commit "f03a046406d4d7fbfd4ed29f554da8f6114049fc")
(revision "1"))