aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-01-25 14:00:23 -0500
committerLudovic Courtès <ludo@gnu.org>2021-02-02 11:05:43 +0100
commitc852d897551f514de95c224fa79e748f48808068 (patch)
tree4668247588d6a4018e5e2260310283d2dbd4263c
parentaee9f696b1d9bd3c41dddc81997a4f0e73081cea (diff)
downloadguix-c852d897551f514de95c224fa79e748f48808068.tar
guix-c852d897551f514de95c224fa79e748f48808068.tar.gz
gnu: Add quark.
* gnu/packages/web.scm (quark): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/web.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8cbcfd011e..879eb160ea 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8015,3 +8015,41 @@ handling library written in C89 (\"ANSI C\"). uriparser is fast and supports
Unicode.")
(home-page "https://uriparser.github.io/")
(license license:bsd-3))))
+
+(define-public quark
+ ;; No releases yet
+ (let ((revision "0")
+ (commit "c6a9055e5a30be570e30da8d216c39662c3a3f99"))
+ (package
+ (name "quark")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.suckless.org/quark/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1znvnr30xi5vgd6n3wvgv9pwj992zpzzjk0fmq28ydf1l6kqvkm7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (home-page "https://tools.suckless.org/quark/")
+ (synopsis "Small and simple HTTP GET/HEAD-only web server for static
+content")
+ (description "Quark is an extremely small and simple HTTP GET/HEAD only
+web server for static content. TLS is not natively supported and should be
+provided by a TLS reverse proxy (e.g. tlstunnel, hitch or stunnel).")
+ (license license:isc)
+
+ ;; XXX: Ignore this CVE to work around a name clash with the unrelated
+ ;; "cpe:2.3:a:comelz:quark" package. The proper fix is for (guix cve)
+ ;; to account for "vendor names".
+ (properties '((lint-hidden-cve . ("CVE-2019-15520")))))))