aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandr Vityazev <avityazew@gmail.com>2021-01-30 23:40:46 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-02 09:13:20 +0100
commitb66d9db336a88aca386ee21c5821a8f98789205a (patch)
tree2576c2b89d25c7101bdb2a7d1d3244062975e868
parent796c9b0bf582399112ab76a35dcd9ae42a88b19b (diff)
downloadguix-b66d9db336a88aca386ee21c5821a8f98789205a.tar
guix-b66d9db336a88aca386ee21c5821a8f98789205a.tar.gz
gnu: emacs-imenu-list: Update to 0.8-0.46008.
* gnu/packages/emacs-xyz.scm (emacs-imenu-list): Update to 0.8-0.46008. Fixes in that commit adapt the display function for changes in emacs 27.0.50. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 23 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 395be23aaa..eaf2bf4900 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2610,29 +2610,32 @@ using the DOT syntax, and use Graphviz to convert these files to diagrams.")
(license license:gpl2+)))
(define-public emacs-imenu-list
- (package
- (name "emacs-imenu-list")
- (version "0.8")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/bmag/imenu-list")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "13xh9bdl3k6ccfq83wjmkpi4269qahv4davki4wq18dr4amrzhlx"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/bmag/imenu-list")
- (synopsis
- "Automatically tracks the current buffer's imenu entries")
- (description
- "This Emacs minor mode creates an automatically updated buffer called
+ (let ((commit "46008738f8fef578a763c308cf6695e5b4d4aa77")
+ (revision "0")
+ (version "0.8"))
+ (package
+ (name "emacs-imenu-list")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/bmag/imenu-list")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14l3yw9y1nk103s7z5i1fmd6kvlb2p6ayi6sf9l1x1ydg9glrpl8"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bmag/imenu-list")
+ (synopsis
+ "Automatically tracks the current buffer's imenu entries")
+ (description
+ "This Emacs minor mode creates an automatically updated buffer called
@code{*Ilist*} that is populated with the current buffer's imenu entries.
This buffer is typically shown as a sidebar (Emacs vertically splits the
window).")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-mmm-mode
(package