aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2021-01-27 20:44:42 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-02 10:24:23 +0100
commit966bdd118172d12b39fd2e97e98ec15b0865a4db (patch)
treeaec1f4a6e6815f640214519b592a48b1542b557e
parent13b2c44e5abe329e4fad6364601e579d2bddfe1c (diff)
downloadguix-966bdd118172d12b39fd2e97e98ec15b0865a4db.tar
guix-966bdd118172d12b39fd2e97e98ec15b0865a4db.tar.gz
gnu: Add md4c.
* gnu/packages/markup.scm (md4c): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/markup.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index af08774c70..95a3eb269e 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 EuAndreh <eu@euandre.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -277,3 +278,25 @@ Smu was started as a rewrite of Markdown but became something more
lightweight and consistent. The biggest difference between Markdown
and smu is that smu doesn't support reference style links.")
(license x11)))
+
+(define-public md4c
+ (package
+ (name "md4c")
+ (version "0.4.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mity/md4c/")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0m3202zzjvw4k7jw66z1qi3cbisxzvplq5alkygpifvhzm81gwwx"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f))
+ (home-page "https://github.com/mity/md4c/")
+ (synopsis "C Markdown parser compliant to CommonMark")
+ (description "MD4C is a C Markdown parser with a
+SAX-like interface. It is compliant to the CommonMark specification,
+with a few extensions.")
+ (license expat)))