aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-02 09:57:03 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-02 10:24:24 +0100
commit8eb32ee0598308c9527e4d58e93456ac4717ea62 (patch)
treecb15cde09b8789671fd0502e0a7364156ecd9b4e
parente5c1348a8c4176325001578b8d285d241a44609f (diff)
downloadguix-8eb32ee0598308c9527e4d58e93456ac4717ea62.tar
guix-8eb32ee0598308c9527e4d58e93456ac4717ea62.tar.gz
gnu: Add python-yamllint.
* gnu/packages/python-xyz.scm (python-yamllint): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2a392d69c5..3d29bd5931 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17798,6 +17798,29 @@ user's @file{~/Trash} directory.")
"@code{pyfavicon} is an async favicon fetcher.")
(license license:expat)))
+(define-public python-yamllint
+ (package
+ (name "python-yamllint")
+ (version "1.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "yamllint" version))
+ (sha256
+ (base32 "11qhs1jk9pwvyk5k3q5blh9sq42dh1ywdf1f3i2zixf7hncwir5h"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pathspec" ,python-pathspec)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/adrienverge/yamllint")
+ (synopsis "Linter for YAML files")
+ (description
+ "Yamllint is a linter for YAML files. yamllint does not only check for
+syntax validity, but for weirdnesses like key repetition and cosmetic problems
+such as lines length, trailing spaces, indentation, etc.")
+ (license license:gpl3+)))
+
(define-public python-yapf
(package
(name "python-yapf")