aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-02-01 20:16:38 +0000
committerChristopher Baines <mail@cbaines.net>2021-02-02 19:29:52 +0000
commit5fc40f747873500adb268304156ada8823dc2358 (patch)
tree2ea9a2f7b131a7b961fb3cbb96560284828f8237
parenteee86c6e5bd99102aa08d0c9be4407738abeb10d (diff)
downloadguix-5fc40f747873500adb268304156ada8823dc2358.tar
guix-5fc40f747873500adb268304156ada8823dc2358.tar.gz
gnu: plover: Update to 4.0.0.dev8.
This moves from Python 2 to Python 3. This is a dev release, but from nearly 2 years ago. Backing up your plover.cfg is advised by the release notes when upgrading from version 3 to 4. * gnu/packages/stenography.scm (plover): Update to 4.0.0.dev8. [arguments]: Remove. [native-inputs]: Switch to Python 3 package variants. [inputs]: Switch to Python 3 package variants, and add python-pyqt.
-rw-r--r--gnu/packages/stenography.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/stenography.scm b/gnu/packages/stenography.scm
index c462deacfa..979b2c29ef 100644
--- a/gnu/packages/stenography.scm
+++ b/gnu/packages/stenography.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages check)
#:use-module (gnu packages libusb)
#:use-module (gnu packages python)
@@ -31,7 +33,7 @@
(define-public plover
(package
(name "plover")
- (version "3.1.1")
+ (version "4.0.0.dev8")
(source
(origin
(method git-fetch)
@@ -40,21 +42,21 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "114rlxvq471fyifwcdcgdad79ak7q3w2lk8z9nqhz1i9fg05721c"))))
+ (base32 "1b2ys77bkjsdmyg97i7lq3lj45q56bycvsm06d4rs656kxhvc0a3"))))
(build-system python-build-system)
- (arguments
- `(#:python ,python-2))
(native-inputs
- `(("python2-mock" ,python2-mock)
- ("python2-pytest" ,python2-pytest)
- ("python2-setuptools-scm" ,python2-setuptools-scm)))
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
(inputs
- `(("python2-appdirs" ,python2-appdirs)
- ("python2-dbus" ,python2-dbus)
- ("python2-hidapi" ,python2-hidapi)
- ("python2-pyserial" ,python2-pyserial)
- ("python2-wxpython" ,python2-wxpython)
- ("python2-xlib" ,python2-xlib)))
+ `(("python-appdirs" ,python-appdirs)
+ ("python-pyqt" ,python-pyqt)
+ ("python-babel" ,python-babel)
+ ("python-dbus" ,python-dbus)
+ ("python-hidapi" ,python-hidapi)
+ ("python-pyserial" ,python-pyserial)
+ ("python-wxpython" ,python-wxpython)
+ ("python-xlib" ,python-xlib)))
(home-page "https://www.openstenoproject.org/plover/")
(synopsis "Stenography engine")
(description