aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-02 21:57:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-02 22:02:22 +0100
commit4532a1575b8159054c90d3f16ca60d9b61777c25 (patch)
treedf146a34c5dbf23e3d5557f287a7da3332bc25ea
parente07f60274ba015fc119784ef6cca6258e9b4104f (diff)
downloadguix-4532a1575b8159054c90d3f16ca60d9b61777c25.tar
guix-4532a1575b8159054c90d3f16ca60d9b61777c25.tar.gz
gnu: Add python-reflink.
* gnu/packages/python-xyz.scm (python-reflink): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 12f8dc40da..e296e3c6e1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23577,6 +23577,32 @@ YAML. It takes care of defaults, overrides, type checking, command-line
integration, human-readable errors, and standard OS-specific locations.")
(license license:expat)))
+(define-public python-reflink
+ (package
+ (name "python-reflink")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "reflink" version))
+ (sha256
+ (base32
+ "0fkf3sd958g9hvr3jwlhnhqqzrwxljrc3grsf3yknh94vf13a9f9"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #false)) ; almost all tests want to run mkfs.btrfs
+ (propagated-inputs
+ `(("python-cffi" ,python-cffi)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://gitlab.com/rubdos/pyreflink")
+ (synopsis "Python wrapper around reflink system call")
+ (description
+ "Python reflink wraps around platform specific @code{reflink}
+implementations.")
+ (license license:expat)))
+
(define-public python-pivy
(package
(name "python-pivy")