aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-02-02 15:47:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-02-02 15:49:17 +0100
commit2c9d481c9098e18accd179f11edc1164e75f228e (patch)
tree98b9f583724c093141e5a4883441de0ccb2a6cf9
parent72fabd8d6ef7fbfd19c1f1ef294b26e3c5a16bbf (diff)
downloadguix-2c9d481c9098e18accd179f11edc1164e75f228e.tar
guix-2c9d481c9098e18accd179f11edc1164e75f228e.tar.gz
gnu: xbindkeys: Refer to xbindkeys in xbindkeys_show.
* gnu/packages/xdisorg.scm (xbindkeys)[arguments]: Add a ‘patch-references’ phase.
-rw-r--r--gnu/packages/xdisorg.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4d1dc8391c..6b4d3f4a8a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -965,7 +965,14 @@ transparent text on your screen.")
(substitute* "xbindkeys_show"
(("^#!.*|^exec wish.*") "")
(("^# \\\\") (string-append "#!" (which "wish"))))
- #t)))))
+ #t))
+ (add-after 'unpack 'patch-references
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "xbindkeys_show"
+ (("\"(xbindkeys)\"" _ command)
+ (format #f "\"~a/bin/~a\"" out command)))
+ #t))))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs