aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2021-02-01 13:47:21 +0100
committerClément Lassieur <clement@lassieur.org>2021-02-02 09:50:02 +0100
commit13b2c44e5abe329e4fad6364601e579d2bddfe1c (patch)
treef974ae58f20f49aadaab36b33033fb1c13ecf3fd
parent0319f9fac2fcbb93219d4ee4eab6e476907f8cae (diff)
downloadguix-13b2c44e5abe329e4fad6364601e579d2bddfe1c.tar
guix-13b2c44e5abe329e4fad6364601e579d2bddfe1c.tar.gz
gnu: emacs-rg: Fix use on remote systems.
* gnu/packages/emacs-xyz.scm (emacs-rg)[inputs]: Remove. Move ripgrep to... [propagated-inputs]: ... here. This also gives access to ripgrep's manual. [arguments]: Replace the full path with the executable name.
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index eaf2bf4900..efd80c14c5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2017, 2018, 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2017, 2018, 2019, 2020 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2017, 2018, 2019, 2020, 2021 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017, 2018 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
@@ -3851,19 +3851,18 @@ result.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'hardcode-rg-path
- ;; Hardcode the path to ripgrep.
+ (add-after 'unpack 'remove-rg-path
+ ;; Remove the path to ripgrep so that it works on remote systems.
(lambda _
(let ((file "rg.el"))
(chmod file #o644)
(emacs-substitute-sexps file
- ("(defcustom rg-executable" (which "rg")))))))))
+ ("(defcustom rg-executable" "rg"))))))))
(propagated-inputs
`(("emacs-s" ,emacs-s)
("emacs-transient" ,emacs-transient)
- ("emacs-wgrep" ,emacs-wgrep)))
- (inputs
- `(("ripgrep" ,ripgrep)))
+ ("emacs-wgrep" ,emacs-wgrep)
+ ("ripgrep" ,ripgrep)))
(home-page "https://rgel.readthedocs.io/en/latest/")
(synopsis "Search tool based on @code{ripgrep}")
(description