aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-09-24 14:48:38 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-09-24 14:48:38 +0200
commitff43f128b7c142ae3f758d34137e562e6f7ef0e0 (patch)
treee6981425493c137535d7be863a847e8daf2ed1e0
parenta024eedb1c0a537aa236fa27fe7a94ba6aa3d76c (diff)
downloadguix-ff43f128b7c142ae3f758d34137e562e6f7ef0e0.tar
guix-ff43f128b7c142ae3f758d34137e562e6f7ef0e0.tar.gz
gnu: Add tarlz.
* gnu/packages/compression.scm (tarlz): New variable.
-rw-r--r--gnu/packages/compression.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 97f254ff6e..5622af1fe9 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
+;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2249,3 +2250,31 @@ computations.")
with their error correction data losslessly rearranged for better compression,
to their original, binary CD format.")
(license license:gpl3+)))
+
+(define-public tarlz
+ (package
+ (name "tarlz")
+ (version "0.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/lzip/tarlz/"
+ "tarlz-" version ".tar.lz"))
+ (sha256
+ (base32 "0gpdm6z9pdr5bn31kxg73wm686hhpb5pdf5782pbl5a4xqqhqj90"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("lzip" ,lzip)))
+ (inputs
+ `(("lzlib" ,lzlib)))
+ (home-page "https://www.nongnu.org/lzip/tarlz.html")
+ (synopsis "Combination of the tar archiver and the lzip compressor")
+ (description
+ "Tarlz is a massively parallel (multi-threaded) combined implementation of
+the tar archiver and the lzip compressor. Tarlz creates, lists, and extracts
+archives in a simplified and safer variant of the POSIX pax format compressed
+with lzip, keeping the alignment between tar members and lzip members. The
+resulting multimember tar.lz archive is fully backward compatible with standard
+tar tools like GNU tar, which treat it like any other tar.lz archive. Tarlz
+can append files to the end of such compressed archives.")
+ (license license:gpl2+)))