aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-30 11:40:15 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-24 17:53:02 +0200
commitec9bc07c25ed235a6c160d054cc7089b01756da4 (patch)
tree192769c270b2f39ca4418209514eb3e9d2872605
parent1af5e57d875000bfe878ca8e4435c2899fb66914 (diff)
downloadguix-ec9bc07c25ed235a6c160d054cc7089b01756da4.tar
guix-ec9bc07c25ed235a6c160d054cc7089b01756da4.tar.gz
gnu: Add python-robber.
* gnu/packages/python-xyz.scm (python-robber): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index c0de32b207..4873df4b48 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -999,3 +999,28 @@ any Python VM with basically no runtime overhead.")
;; Foundation License version 2: stdlib-samples/*, mypyc/lib-rt/pythonsupport.h and
;; mypyc/lib-rt/getargs.c
(license (list license:expat license:psfl))))
+
+(define-public python-robber
+ (package
+ (name "python-robber")
+ (version "1.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "robber" version))
+ (sha256
+ (base32
+ "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
+ (build-system python-build-system)
+ ;; There are no tests in the tarball downloaded from PyPI.
+ ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
+ ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.
+ (arguments '(#:tests? #f))
+ (propagated-inputs
+ `(("python-mock" ,python-mock)
+ ("python-termcolor" ,python-termcolor)))
+ ;; URL of the fork used to generate the package available on PyPI.
+ (home-page "https://github.com/EastAgile/robber.py")
+ (synopsis "Test-driven development (TDD) assertion library for Python")
+ (description "Robber is a Python assertion library for test-driven and
+behavior-driven development (TDD and BDD).")
+ (license license:expat)))