aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-09-15 18:07:53 -0300
committerLudovic Courtès <ludo@gnu.org>2020-09-24 17:53:02 +0200
commitdca2f0ea01453bae2109ef0fe8460bcd67a55634 (patch)
tree870bee66297ccc53e7ffd1ea7c0c162b174c8d66
parent7f12756e75b7589477878ba269c6fd86e5af3acd (diff)
downloadguix-dca2f0ea01453bae2109ef0fe8460bcd67a55634.tar
guix-dca2f0ea01453bae2109ef0fe8460bcd67a55634.tar.gz
gnu: Add gtg.
* gnu/packages/gnome.scm (gtg): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4d30ee9d92..510a971e9d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2542,6 +2542,63 @@ That way, you have a clear separation between your data themselves (Model)
and how they are displayed (View).")
(license license:lgpl3+)))
+(define-public gtg
+ (package
+ (name "gtg")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/getting-things-gnome/gtg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r28vyr88rj3kd3cg4gj7sd29wadjchi92wzmbx67d4hlg25h8kk"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/gtg"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)
+ ("python-dbus" ,python-dbus)
+ ("python-liblarch" ,python-liblarch)
+ ("python-pycairo" ,python-pycairo)
+ ("python-pygobject" ,python-pygobject)
+ ("python-pyxdg" ,python-pyxdg)))
+ (home-page "https://wiki.gnome.org/Apps/GTG")
+ (synopsis "Personal organizer for the GNOME desktop")
+ (description
+ "Getting Things GNOME! (GTG) is a personal tasks and TODO list items
+organizer for the GNOME desktop environment inspired by the Getting Things
+Done (GTD) methodology. GTG is designed with flexibility, adaptability,
+and ease of use in mind so it can be used as more than just GTD software.
+GTG is intended to help you track everything you need to do and need to
+know, from small tasks to large projects.")
+ (license license:gpl3+)))
+
(define-public icon-naming-utils
(package
(name "icon-naming-utils")