aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-09-15 18:06:30 -0300
committerLudovic Courtès <ludo@gnu.org>2020-09-24 17:53:02 +0200
commit7f12756e75b7589477878ba269c6fd86e5af3acd (patch)
tree594305a3b929c84453e1f9eca0159be68a003f53
parent8e0c5033b17fcf1e4596ee9a3d52157900acc6fa (diff)
downloadguix-7f12756e75b7589477878ba269c6fd86e5af3acd.tar
guix-7f12756e75b7589477878ba269c6fd86e5af3acd.tar.gz
gnu: Add python-liblarch.
* gnu/packages/gnome.scm (python-liblarch): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f066dd3efe..4d30ee9d92 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2501,6 +2501,47 @@ on the GNOME Desktop with a single simple application.")
for settings shared by various components of the GNOME desktop.")
(license license:lgpl2.1+)))
+(define-public python-liblarch
+ (package
+ (name "python-liblarch")
+ (version "3.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/getting-things-gnome/liblarch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xv2mfvyzipbny3iz8vll77wsqxfwh28xj6bj1ff0l452waph45m"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'start-xserver
+ (lambda* (#:key inputs #:allow-other-keys)
+ (system (format #f "~a/bin/Xvfb :1 &"
+ (assoc-ref inputs "xorg-server")))
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (native-inputs
+ `(("xorg-server" ,xorg-server-for-tests)))
+ (inputs
+ `(("gtk+" ,gtk+)))
+ (propagated-inputs
+ `(("python-pygobject" ,python-pygobject)))
+ (home-page "https://wiki.gnome.org/Projects/liblarch")
+ (synopsis "Library to easily handle complex data structures")
+ (description
+ "Liblarch is a Python library built to easily handle data structures such
+as lists, trees and acyclic graphs. There's also a GTK binding that will
+allow you to use your data structure in a @code{Gtk.Treeview}.
+
+Liblarch support multiple views of one data structure and complex filtering.
+That way, you have a clear separation between your data themselves (Model)
+and how they are displayed (View).")
+ (license license:lgpl3+)))
+
(define-public icon-naming-utils
(package
(name "icon-naming-utils")