aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-09-24 23:17:55 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-09-25 14:02:13 +0200
commit7075082f71d0a68912efd0473fdd537de9d501a7 (patch)
tree4f9c95a0847670a942869baa9b4cfb2a3fbe2670
parentc32f662e399e7036323b8499580e56c06bc8afbb (diff)
downloadguix-7075082f71d0a68912efd0473fdd537de9d501a7.tar
guix-7075082f71d0a68912efd0473fdd537de9d501a7.tar.gz
gnu: Add gnome-latex.
* gnu/packages/gnome.scm (gnome-latex): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/gnome.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 510a971e9d..904ffd1dc2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11125,6 +11125,49 @@ designed to work with various laser/ink-jet peel-off label and business
card sheets that you’ll find at most office supply stores.")
(license license:gpl3+)))
+;; Version 3.38.0 is out but requires tepl>=5 which requires glib>=2.64.
+(define-public gnome-latex
+ (package
+ (name "gnome-latex")
+ (version "3.36.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ "gnome-latex-" version ".tar.xz"))
+ (sha256
+ (base32 "1869kr1zhcp04mzbi67lwgk497w840dbbc7427i9yh9b9s7j6mqn"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (inputs
+ `(("amtk" ,amtk)
+ ("dconf" ,dconf)
+ ("glib" ,glib)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell)
+ ("gtk+" ,gtk+)
+ ("gtksourceview" ,gtksourceview)
+ ("libgee" ,libgee)
+ ("tepl" ,tepl)
+ ("uchardet" ,uchardet)))
+ (home-page "https://wiki.gnome.org/Apps/GNOME-LaTeX")
+ (synopsis "LaTeX editor for the GNOME desktop")
+ (description
+ "GNOME LaTeX is a LaTeX editor for the GNOME desktop. It has features
+such as build tools, completion of LaTeX commands, structure navigation,
+symbol tables, document templates, project management, spell-checking, menus
+and toolbars.")
+ (license license:gpl3+)))
+
(define-public libratbag
(package
(name "libratbag")