aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHamzeh Nasajpour <h.nasajpour@pantherx.org>2020-09-23 11:41:25 +0330
committerEfraim Flashner <efraim@flashner.co.il>2020-09-23 12:13:48 +0300
commit6e398663c3da8daa905e2e544acb1280a1b9f793 (patch)
treec2d6f0a90626c00039bdc5f45c9d299e48a9e213
parent5c2db516f97660c9f8c1a639493997b2b4a2bbab (diff)
downloadguix-6e398663c3da8daa905e2e544acb1280a1b9f793.tar
guix-6e398663c3da8daa905e2e544acb1280a1b9f793.tar.gz
gnu: nng: Build as a shared library.
* gnu/packages/networking.scm (nng)[arguments]: Add configure-flag to build as a shared library. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/networking.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 89e47a6726..8b46bd7d24 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Jesse Dowell <jessedowell@gmail.com>
+;;; Copyright © 2020 Hamzeh Nasajpour <h.nasajpour@pantherx.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -419,7 +420,8 @@ at the link-layer level.")
(arguments
`(#:configure-flags
(list "-DNNG_ENABLE_COVERAGE=ON"
- "-DNNG_ENABLE_TLS=ON")
+ "-DNNG_ENABLE_TLS=ON"
+ "-DBUILD_SHARED_LIBS=ON")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'disable-failing-tests