aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-24 17:15:43 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-24 17:15:43 +0300
commit6c1f173650728eb9d5f21254686e9b923808a89b (patch)
tree5c10aaf71a1b1fed07b156a751930f4c73b329ee
parentff43f128b7c142ae3f758d34137e562e6f7ef0e0 (diff)
downloadguix-6c1f173650728eb9d5f21254686e9b923808a89b.tar
guix-6c1f173650728eb9d5f21254686e9b923808a89b.tar.gz
gnu: footswitch: Use cc-for-target.
* gnu/packages/accessibility.scm (footswitch)[arguments]: Replace hard-coded gcc with cc-for-target in make-flags.
-rw-r--r--gnu/packages/accessibility.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/accessibility.scm b/gnu/packages/accessibility.scm
index 14ce805aef..34031545dd 100644
--- a/gnu/packages/accessibility.scm
+++ b/gnu/packages/accessibility.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Andrew Miloradovsky <andrew@interpretmath.pw>
+;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -272,7 +273,7 @@ available to help to click.")
`(("hidapi" ,hidapi)))
(arguments
`(#:tests? #f ; no tests
- #:make-flags (list "CC=gcc")
+ #:make-flags (list (string-append "CC=" ,(cc-for-target)))
#:phases (modify-phases %standard-phases
(delete 'configure)
;; Install target in the Makefile does not work for Guix