aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2020-09-23 21:04:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-09-23 21:04:58 +0200
commit40131b75c4fb23ec0ac6beba3618b07c23865ad3 (patch)
tree585358b2a93c0afb51601ff384fcc903de0b938c
parent97e98e22691d3d1ecf35afc2ba2c961fdbd3cc7e (diff)
downloadguix-40131b75c4fb23ec0ac6beba3618b07c23865ad3.tar
guix-40131b75c4fb23ec0ac6beba3618b07c23865ad3.tar.gz
gnu: Add emacs-quickrun.
* gnu/packages/emacs-xyz.scm (emacs-quickrun): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6b82c94a08..43ef7364e9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -78,6 +78,7 @@
;;; Copyright © 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 Peng Mei Yu <i@pengmeiyu.com>
+;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7490,6 +7491,29 @@ be removed from the front. This type of data structure is sometimes called an
\"output-restricted deque\".")
(license license:gpl3+)))
+(define-public emacs-quickrun
+ (package
+ (name "emacs-quickrun")
+ (version "2.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacsorphanage/quickrun")
+ (commit version)))
+ (sha256
+ (base32 "0a1n2v09h0n7d9p2izflqqang4ny0b46dlqvmxvkkik4bb6f4wcz"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emacsorphanage/quickrun")
+ (synopsis "Execute editing buffer and show its output quickly")
+ (description
+ "This package evaluates the content of a buffer, or region, and displays
+the result. Quickrun executes not only script languages (Perl, Ruby, Python
+etc), but also compiling languages (C, C++, Go, Java etc) and markup
+languages.")
+ (license license:gpl3+)))
+
(define-public emacs-pkg-info
(package
(name "emacs-pkg-info")