aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-24 19:45:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-24 20:06:41 +0300
commit3d0c0ae661ccafcab030f27a77179c772039f682 (patch)
tree0883214edb342d4ed9d945f3d25332a6906a8bc3
parente3b40906ebaedf67275acfe86a506c1351b9aace (diff)
downloadguix-3d0c0ae661ccafcab030f27a77179c772039f682.tar
guix-3d0c0ae661ccafcab030f27a77179c772039f682.tar.gz
gnu: java-rsyntaxtextarea: Don't use unstable tarball.
* gnu/packages/textutils.scm (java-rsyntaxtextarea)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/textutils.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 6ee3442c76..6653d01a31 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2016, 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
@@ -850,14 +850,14 @@ Filter, list, or split a tar file.
(name "java-rsyntaxtextarea")
(version "2.6.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/bobbylight/"
- "RSyntaxTextArea/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bobbylight/RSyntaxTextArea")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0c5mqg2klj5rvf8fhycrli8rf6s37l9p7a8knw9gpp65r1c120q2"))))
+ "0dyflzvxq2wvs0rgqfyi5yzzrb6r4bzw2dm8cl304dakxk38ddys"))))
(build-system ant-build-system)
(arguments
`(;; FIXME: some tests fail because locale resources cannot be found.