aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-09-26 21:39:17 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-09-26 21:47:38 +0300
commit3876ed32f25e160c47ba046d987ad9097b2bf0cb (patch)
tree29bf17bf7de7665d5e2357169f3348d953393e1a
parent0939462e3f81bc98b38bdb7610e6a80ca1cbaa1b (diff)
downloadguix-3876ed32f25e160c47ba046d987ad9097b2bf0cb.tar
guix-3876ed32f25e160c47ba046d987ad9097b2bf0cb.tar.gz
gnu: Add webssh.
* gnu/packages/ssh.scm (webssh): New variable.
-rw-r--r--gnu/packages/ssh.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 23f347dd10..3e0f5be077 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -57,6 +57,8 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages texinfo)
@@ -852,3 +854,39 @@ program doesn't depend on any cryptographic libraries. It's a simple,
single-threaded, standalone C program. It uses @code{poll()} to trap multiple
clients at a time.")
(license license:unlicense)))
+
+(define-public webssh
+ (package
+ (name "webssh")
+ (version "1.5.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/huashengdun/webssh")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l4bwzaifsd6pl120d400qkhvaznj2ck1lvwg76ycb08jsk6gpaz"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-paramiko" ,python-paramiko)
+ ("python-tornado" ,python-tornado)))
+ (home-page "https://webssh.huashengdun.org/")
+ (synopsis "Web application to be used as an SSH client")
+ (description "This package provides a web application to be used as an SSH
+client.
+
+Features:
+@itemize @bullet
+@item SSH password authentication supported, including empty password.
+@item SSH public-key authentication supported, including DSA RSA ECDSA
+Ed25519 keys.
+@item Encrypted keys supported.
+@item Two-Factor Authentication (time-based one-time password) supported.
+@item Fullscreen terminal supported.
+@item Terminal window resizable.
+@item Auto detect the ssh server's default encoding.
+@item Modern browsers are supported.
+@end itemize")
+ (license license:expat)))