aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-09-24 15:08:15 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-24 17:53:01 +0200
commit215b49a8814093ef6b953b84efe30de1c3111665 (patch)
treefbf0469b7b75b8ef0f6c40966917bbc88cdebc8f
parentaea2a0f967e644a98baff1bbe10f85b08b7e1fc6 (diff)
downloadguix-215b49a8814093ef6b953b84efe30de1c3111665.tar
guix-215b49a8814093ef6b953b84efe30de1c3111665.tar.gz
gnu: openmpi: Have 'mpirun' look for executables under $prefix.
* gnu/packages/mpi.scm (openmpi)[arguments]: Add "--enable-mpirun-prefix-by-default" to #:configure-flags.
-rw-r--r--gnu/packages/mpi.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index d831766ef2..06a82cce95 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Dave Love <fx@gnu.org>
@@ -221,6 +221,10 @@ bind processes, and much more.")
"--with-hwloc=external"
"--with-libevent"
+ ;; Help 'orterun' and 'mpirun' find their tools
+ ;; under $prefix by default.
+ "--enable-mpirun-prefix-by-default"
+
;; InfiniBand support
"--enable-openib-control-hdr-padding"
"--enable-openib-dynamic-sl"