aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-18 10:02:33 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:13 +0100
commite08aa7a38035d575a9c0052619ef78e1d5772ae6 (patch)
tree7b449c87d491ef83d525e5181211544dafffaa20
parente03271ef2851f44c09334615c9d09f002ebf7d0e (diff)
downloadguix-e08aa7a38035d575a9c0052619ef78e1d5772ae6.tar
guix-e08aa7a38035d575a9c0052619ef78e1d5772ae6.tar.gz
gnu: python-reproject: Update to 0.13.1.
* gnu/packages/astronomy.scm (python-reproject): Update to 0.13.1. [arguments]: <#:phases>: Add 'create-setup.py phase. [native-inputs]: Remove python-cython; add python-cython-3. Change-Id: I77845fa1a9748901bc08235ba95060d39b64e467
-rw-r--r--gnu/packages/astronomy.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 26425bf133..efd364277b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2732,13 +2732,13 @@ setup(ext_modules=get_extensions())")))))
(define-public python-reproject
(package
(name "python-reproject")
- (version "0.13.0")
+ (version "0.13.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "reproject" version))
(sha256
- (base32 "1qkjbx8xsawhi1gjzqimais3crvkwgbzy1pr51x6anjjln88rgll"))))
+ (base32 "1xk809h2j3zj37l5lx4l87zanf9zxbxajcrff2b2f2i0jpnmxqv3"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -2754,6 +2754,17 @@ setup(ext_modules=get_extensions())")))))
#:tests? #f
#:phases
#~(modify-phases %standard-phases
+ ;; setup.py was removed in a659a260bdd7635cddc8f33c4ea04a3b6d8c1f84
+ ;; for some unknown reason, which caused the package to fail to
+ ;; build. It is being recreated based on that commit.
+ ;; TODO: Check how to implement it in python-build-system.
+ (add-after 'unpack 'create-setup.py
+ (lambda _
+ (call-with-output-file "setup.py"
+ (lambda (port)
+ (format port "from setuptools import setup
+from extension_helpers import get_extensions
+setup(ext_modules=get_extensions())")))))
(add-before 'install 'writable-compiler
(lambda _
(make-file-writable "reproject/_compiler.c")))
@@ -2778,7 +2789,7 @@ setup(ext_modules=get_extensions())")))))
python-shapely
python-zarr))
(native-inputs
- (list python-cython
+ (list python-cython-3
python-extension-helpers
python-pytest-astropy
python-semantic-version