aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSughosha via Guix-patches via <guix-patches@gnu.org>2024-04-09 00:48:51 +0530
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-05-01 00:21:37 +0800
commit40cf627160f14b7077094e1999de189309e41058 (patch)
tree6c9fe0b09564242cc2f556e420ca80709432b15b
parent570ccaaedcb1e03d29c6cb420b2104627e57df63 (diff)
downloadguix-40cf627160f14b7077094e1999de189309e41058.tar
guix-40cf627160f14b7077094e1999de189309e41058.tar.gz
gnu: Add phonon-backend-vlc.
* gnu/packages/kde-frameworks.scm (phonon-plugin-vlc): New variable. Change-Id: I5a680d55782cbfcd6349efc64cce36457f456377 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
-rw-r--r--gnu/packages/kde-frameworks.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 8991c36f89..08329820fa 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -288,6 +288,33 @@ Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
;; license: source files mention "either version 2.1 or 3"
(license (list license:lgpl2.1 license:lgpl3))))
+(define-public phonon-backend-vlc
+ (package
+ (name "phonon-backend-vlc")
+ (version "0.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/phonon/"
+ name "/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "19f9wzff4nr36ryq18i6qvsq5kqxfkpqsmsvrarr8jqy8pf7k11k"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "-DPHONON_BUILD_QT6=OFF")))
+ (native-inputs
+ (list extra-cmake-modules qttools-5))
+ (inputs
+ (list phonon qtbase-5 vlc))
+ (home-page "https://community.kde.org/Phonon")
+ (synopsis "Phonon backend which uses VLC")
+ (description "Phonon makes use of backend libraries to provide sound.
+Phonon-VLC is a backend based on the VLC multimedia library.")
+ (license license:lgpl2.1)))
+
;; Tier 1
;;