aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-06-07 21:20:08 +0100
committerChristopher Baines <mail@cbaines.net>2020-06-13 12:02:13 +0100
commit3857aba7ab25c50d64a6d7468d2b5b09bc4f5d60 (patch)
treeab7c7fc8995fe0d7a32dd5ba132374670191d130
parente51175f68631e8eabd00bbbe546999ad3593cb26 (diff)
downloadguix-3857aba7ab25c50d64a6d7468d2b5b09bc4f5d60.tar
guix-3857aba7ab25c50d64a6d7468d2b5b09bc4f5d60.tar.gz
gnome: gnome-desktop: Add bubblewrap as an input.
This is expected to be available, oddly as libseccomp is available. These changes fix thumbnails for Nautilus. * gnu/packages/gnome.scm (gnome-desktop)[arguments]: Add 'patch-bubblewrap phase. [inputs]: Add bubblewrap.
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e1b21c37db..13769a7c88 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1286,6 +1286,19 @@ offline sources, providing a centralized place for managing your contacts.")
(("\"locale\"")
(string-append "\"" libc "/bin/locale\"")))
#t)))
+ (add-before 'configure 'patch-bubblewrap
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "libgnome-desktop/gnome-desktop-thumbnail-script.c"
+ (("\"bwrap\",")
+ (string-append "\"" (which "bwrap") "\","))
+ (("\"--ro-bind\", \"/usr\", \"/usr\",")
+ (string-append "\"--ro-bind\", \""
+ (%store-directory)
+ "\", \""
+ (%store-directory)
+ "\","))
+ (("\"--ro-bind\", \"/etc/ld.so.cache\", \"/etc/ld.so.cache\",") ""))
+ #t))
(add-before 'check 'pre-check
(lambda* (#:key inputs #:allow-other-keys)
;; Tests require a running X server and locales.
@@ -1315,6 +1328,7 @@ offline sources, providing a centralized place for managing your contacts.")
(inputs
`(("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)
+ ("bubblewrap" ,bubblewrap)
("libxext" ,libxext)
("libxkbfile" ,libxkbfile)
("libxrandr" ,libxrandr)))