aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-20 23:00:05 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:14 +0100
commit147f1f2e0d3fe3b267f3e0f7c1d859bcb779c850 (patch)
tree2c3c5a0df277c21efabdc43fd12f8391d930a0c3
parentbba6eca50967d84c8a4dbddf90c9c874ae2484aa (diff)
downloadguix-147f1f2e0d3fe3b267f3e0f7c1d859bcb779c850.tar
guix-147f1f2e0d3fe3b267f3e0f7c1d859bcb779c850.tar.gz
gnu: Add psfex.
* gnu/packages/astronomy.scm (psfex): New variable. Change-Id: I073df933b244811cd09343ea4951f481ad76b075
-rw-r--r--gnu/packages/astronomy.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 740dd7dbab..560d5491e7 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1131,6 +1131,51 @@ programs for the manipulation and analysis of astronomical data.")
from Stark Labs.")
(license license:bsd-3)))
+(define-public psfex
+ (package
+ (name "psfex")
+ (version "3.24.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/psfex")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ykgzyxnxjxqk6b8jng006wjilg4fqaxclpfn8plg6brk1qf39sn"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "CPPFLAGS=-fcommon"
+ "--enable-openblas"
+ "--enable-plplot"
+ (string-append "--with-fftw-libdir="
+ #$(this-package-input "fftw") "/lib")
+ (string-append "--with-fftw-incdir="
+ #$(this-package-input "fftw") "/include")
+ (string-append "--with-openblas-libdir="
+ #$(this-package-input "openblas") "/lib")
+ (string-append "--with-openblas-incdir="
+ #$(this-package-input "openblas") "/include")
+ (string-append "--with-plplot-libdir="
+ #$(this-package-input "plplot") "/lib")
+ (string-append "--with-plplot-incdir="
+ #$(this-package-input "plplot") "/include"))))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (inputs
+ (list openblas fftw fftwf plplot))
+ (home-page "https://www.astromatic.net/software/psfex/")
+ (synopsis "Astronomical PSF modelling and quality assessment")
+ (description
+ "@acronym{PSFEx, PSF Extractor} extracts models of the @acronym{PSF,
+Point Spread Function} from FITS images processed with SExtractor, and
+measures the quality of images. The generated PSF models can be used for
+model-fitting photometry or morphological analyses.")
+ (license license:gpl3+)))
+
(define-public sextractor
(package
(name "sextractor")