aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2021-11-10 03:53:37 +0100
committerLeo Famulari <leo@famulari.name>2021-12-08 14:26:39 -0500
commit0ba4e94e8448e6c27cceb690b085c8d8cf66e577 (patch)
treea4aa7e4a5538621f224286057c99032d1110e3b4
parent8ac2d303e4e01fb5a5b22e7fd78f174e0a931afd (diff)
downloadguix-0ba4e94e8448e6c27cceb690b085c8d8cf66e577.tar
guix-0ba4e94e8448e6c27cceb690b085c8d8cf66e577.tar.gz
gnu: Add realmd.
* gnu/packages/admin.scm (realmd): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/admin.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index e640149a51..8e55d980e0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -128,6 +129,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
@@ -1531,6 +1533,56 @@ console window to allow commands to be interactively run on multiple servers
over ssh connections.")
(license license:gpl2+)))
+(define-public realmd
+ (package
+ (name "realmd")
+ (version "0.17.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/freedesktop/realmd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c6q2a86kk2f1akzc36nh52hfwsmmc0mbp6ayyjxj4zsyk9zx5bf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--with-systemd-unit-dir=no"
+ "--with-systemd-journal=no"
+ "--with-distro=GNU guix"
+ "--disable-doc")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'fix-service
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; GNU Guix does not have service config file, therefore we remove
+ ;; the line that copies the file.
+ (substitute* "Makefile"
+ ((".*/service/realmd-.*") "")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("glib-bin" ,glib "bin")
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (inputs
+ `(("glib" ,glib)
+ ("mit-krb5" ,mit-krb5)
+ ("openldap" ,openldap)
+ ("polkit" ,polkit)))
+ (synopsis "DBus service for network authentication")
+ (description "This package provides an on demand system DBus service.
+It allows callers to configure network authentication and domain membership
+in a standard way. Realmd discovers information about the domain or realm
+automatically and does not require complicated configuration in order to join
+a domain or realm. Dbus system service that manages discovery and enrollment in
+realms/domains like Active Directory or IPA.")
+ (home-page "https://www.freedesktop.org/software/realmd/")
+ (license license:lgpl2.1+)))
+
(define-public rename
(package
(name "rename")