aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-29 13:50:26 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 18:29:48 +0200
commitccf2d02a198eed2c400caa4d9f792281dd9bbd2b (patch)
tree3cc2093e0cc97b9a53de01f1099dca5dca786b8a
parent8d58b5b2a7ea0fe4d106f355951687086887cf3f (diff)
downloadguix-ccf2d02a198eed2c400caa4d9f792281dd9bbd2b.tar
guix-ccf2d02a198eed2c400caa4d9f792281dd9bbd2b.tar.gz
gnu: Add r-hardhat.
* gnu/packages/cran.scm (r-hardhat): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c3e0ea35b2..682e4ffde1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22662,6 +22662,39 @@ and clustering large sequence datasets using fast alignment-free k-mer
counting and recursive k-means partitioning.")
(license license:gpl3)))
+(define-public r-hardhat
+ (package
+ (name "r-hardhat")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "hardhat" version))
+ (sha256
+ (base32
+ "10x8fw0skaqci03v2qqpbradbra9arm3s5pskcwm4wricd2imr40"))))
+ (properties `((upstream-name . "hardhat")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-glue" ,r-glue)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)
+ ("r-vctrs" ,r-vctrs)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/tidymodels/hardhat")
+ (synopsis "Construct modeling packages")
+ (description
+ "Building modeling packages is hard. A large amount of effort generally
+goes into providing an implementation for a new method that is efficient,
+fast, and correct, but often less emphasis is put on the user interface. A
+good interface requires specialized knowledge about S3 methods and formulas,
+which the average package developer might not have. The goal of
+@code{hardhat} is to reduce the burden around building new modeling packages
+by providing functionality for preprocessing, predicting, and validating
+input.")
+ (license license:expat)))
+
(define-public r-shapforxgboost
(package
(name "r-shapforxgboost")