aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-09-11 12:45:24 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-09-12 02:19:05 +0200
commitc6e8d17b02a840fb742437dacbcde9ca293a8f2e (patch)
treedc97aec547385b67f854a9dceb7e5506a2840751
parentc519a5b5b6a249b609cf37565dd837157809b4b1 (diff)
downloadguix-c6e8d17b02a840fb742437dacbcde9ca293a8f2e.tar
guix-c6e8d17b02a840fb742437dacbcde9ca293a8f2e.tar.gz
gnu: Add python-potr.
* gnu/packages/python-crypto.scm (python-potr): New variable.
-rw-r--r--gnu/packages/python-crypto.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 76f2ba18e1..22b1a1ebe3 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -64,6 +64,30 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
+(define-public python-potr
+ (package
+ (name "python-potr")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/python-otr/pure-python-otr.git")
+ (commit version)))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "1hzw6h01fm216nmipyylgz0zybd80w1xsk12m7djycnhqrnrvvv1"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pycrypto" ,python-pycrypto)))
+ (synopsis "Python OTR Implementation")
+ (description "Python OTR is an Off-The-Record Protocol Implementation in
+Python. It does not bind to libotr.")
+ (home-page "https://github.com/python-otr/pure-python-otr")
+ (license license:lgpl3+)))
+
(define-public python-base58
(package
(name "python-base58")