aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-11 20:08:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 21:59:12 +0200
commitb31c364467470a7d4f7eb46fb2c5ca13c9ec2121 (patch)
treed52f7569b18b38a4906f0c7a667aaa676c9197f5
parent30aaee33066b9479cfc353f97f5f83f2e64517ef (diff)
downloadguix-b31c364467470a7d4f7eb46fb2c5ca13c9ec2121.tar
guix-b31c364467470a7d4f7eb46fb2c5ca13c9ec2121.tar.gz
gnu: r-maldiquant: Move to (gnu packages cran).
* gnu/packages/bioinformatics.scm (r-maldiquant): Move from here... * gnu/packages/cran.scm (r-maldiquant): ...to here. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioinformatics.scm26
-rw-r--r--gnu/packages/cran.scm26
2 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 40c6363859..fecb3c072d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9425,32 +9425,6 @@ for analyzing gene-level association tests in meta-analyses for binary
trait.")
(license license:gpl3)))
-(define-public r-maldiquant
- (package
- (name "r-maldiquant")
- (version "1.19.3")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "MALDIquant" version))
- (sha256
- (base32
- "0b7kdz3x4sdq413h1q09l1qhcvdnnwv6fqsqwllks1cd3xy34c57"))))
- (properties `((upstream-name . "MALDIquant")))
- (build-system r-build-system)
- (home-page "https://cran.r-project.org/web/packages/MALDIquant")
- (synopsis "Quantitative analysis of mass spectrometry data")
- (description
- "This package provides a complete analysis pipeline for matrix-assisted
-laser desorption/ionization-time-of-flight (MALDI-TOF) and other
-two-dimensional mass spectrometry data. In addition to commonly used plotting
-and processing methods it includes distinctive features, namely baseline
-subtraction methods such as morphological filters (TopHat) or the
-statistics-sensitive non-linear iterative peak-clipping algorithm (SNIP), peak
-alignment using warping functions, handling of replicated measurements as well
-as allowing spectra with different resolutions.")
- (license license:gpl3+)))
-
(define-public r-protgenerics
(package
(name "r-protgenerics")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fec9947d0d..3657ae1515 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24405,3 +24405,29 @@ designs. Broman et al. (2018) <doi:10.1534/genetics.118.301595>.")
data (variant call format, e.g. VCF or BCF) or meta-analysis results in R.")
;; Any version of the GPL is acceptable
(license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-maldiquant
+ (package
+ (name "r-maldiquant")
+ (version "1.19.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "MALDIquant" version))
+ (sha256
+ (base32
+ "0b7kdz3x4sdq413h1q09l1qhcvdnnwv6fqsqwllks1cd3xy34c57"))))
+ (properties `((upstream-name . "MALDIquant")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/MALDIquant")
+ (synopsis "Quantitative analysis of mass spectrometry data")
+ (description
+ "This package provides a complete analysis pipeline for matrix-assisted
+laser desorption/ionization-time-of-flight (MALDI-TOF) and other
+two-dimensional mass spectrometry data. In addition to commonly used plotting
+and processing methods it includes distinctive features, namely baseline
+subtraction methods such as morphological filters (TopHat) or the
+statistics-sensitive non-linear iterative peak-clipping algorithm (SNIP), peak
+alignment using warping functions, handling of replicated measurements as well
+as allowing spectra with different resolutions.")
+ (license license:gpl3+)))