aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-29 16:03:38 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 19:18:46 +0200
commit962c7ceff5c6497e23d26f44bd08147e4cb9646b (patch)
treefb8f326d7f36cb8baadb3d7caf1b756fe384705b
parent4a1377000305a923ea46f88a07a55ee38cf82bfc (diff)
downloadguix-962c7ceff5c6497e23d26f44bd08147e4cb9646b.tar
guix-962c7ceff5c6497e23d26f44bd08147e4cb9646b.tar.gz
gnu: Add r-perm.
* gnu/packages/cran.scm (r-perm): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d67dcc9e93..f3693fbec5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24213,3 +24213,26 @@ used for univariate censored data (see data set @code{cosmesis}), and for
censored data with competing risks (see data set @code{menopause}). The
package also provides functions to visualize the observed data and the MLE.")
(license license:gpl2+)))
+
+(define-public r-perm
+ (package
+ (name "r-perm")
+ (version "1.0-0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "perm" version))
+ (sha256
+ (base32
+ "0075awl66ynv10vypg63fcxk33qzvxddrp8mi4w08ysvimcyxijk"))))
+ (properties `((upstream-name . "perm")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/perm/")
+ (synopsis "Exact or asymptotic permutation tests")
+ (description
+ "This package provides several methods for performing permutation tests.
+It has three main functions, to perform linear permutation tests. These tests
+are tests where the test statistic is the sum of the product of a
+covariate (usually group indicator) and the scores.")
+ ;; Any version of the GPL
+ (license license:gpl2+)))