aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 12:08:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 12:10:03 +0300
commit88b2c1aae21a28957ef9b53f3e9aa82355a9027e (patch)
treece8133948a8cf30bbd362965606c430bc97b7885
parent97a01170398055f3fcb61e844c3314d8d5aec5dd (diff)
downloadguix-88b2c1aae21a28957ef9b53f3e9aa82355a9027e.tar
guix-88b2c1aae21a28957ef9b53f3e9aa82355a9027e.tar.gz
gnu: Add python-pysolr.
* gnu/packages/python-web.scm (python-pysolr): New variable.
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5a2fa1ee7c..6fd430a41f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4368,3 +4368,28 @@ for Python. It is mainly used by the ZODB.")
Agent is a web crawler. It uses the list of registered robots from
@url{http://www.robotstxt.org}.")
(license license:gpl3+)))
+
+(define-public python-pysolr
+ (package
+ (name "python-pysolr")
+ (version "3.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pysolr" version))
+ (sha256
+ (base32
+ "1rj5jmscvxjwcmlfi6hmkj44l4x6n3ln5p7d8d18j566hzmmzw3f"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; Tests require network access.
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/django-haystack/pysolr/")
+ (synopsis "Lightweight python wrapper for Apache Solr")
+ (description
+ "This module provides an interface that queries the Apache Solr server
+using a pure Python implementation.")
+ (license license:bsd-3)))