aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-11 20:08:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 21:59:23 +0200
commit77c73940867e4883e1433f0770d52fccf7e1ee12 (patch)
tree652e43abdb5fc84505b1b40748c879c9b9a38cda
parent415aa8a583a018ed2dd7e97a2045e7bd03a67674 (diff)
downloadguix-77c73940867e4883e1433f0770d52fccf7e1ee12.tar
guix-77c73940867e4883e1433f0770d52fccf7e1ee12.tar.gz
gnu: r-diversitree: Move to (gnu packages cran).
* gnu/packages/bioinformatics.scm (r-diversitree): Move from here... * gnu/packages/cran.scm (r-diversitree): ...to here. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioinformatics.scm31
-rw-r--r--gnu/packages/cran.scm31
2 files changed, 31 insertions, 31 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bec6c1dc4a..6381523009 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13084,37 +13084,6 @@ analyses in addition to large-scale sequence-level searches.")
(supported-systems '("x86_64-linux"))
(license license:bsd-3))))
-(define-public r-diversitree
- (package
- (name "r-diversitree")
- (version "0.9-13")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "diversitree" version))
- (sha256
- (base32
- "00vi4klywi35hd170ksjv3xja3hqqbkcidcnrrlpgv4179k0azix"))))
- (build-system r-build-system)
- (native-inputs
- `(("gfortran" ,gfortran)))
- (inputs `(("fftw" ,fftw) ("gsl" ,gsl)))
- (propagated-inputs
- `(("r-ape" ,r-ape)
- ("r-desolve" ,r-desolve)
- ("r-rcpp" ,r-rcpp)
- ("r-subplex" ,r-subplex)))
- (home-page "https://www.zoology.ubc.ca/prog/diversitree")
- (synopsis "Comparative 'phylogenetic' analyses of diversification")
- (description "This package contains a number of comparative \"phylogenetic\"
-methods, mostly focusing on analysing diversification and character evolution.
-Contains implementations of \"BiSSE\" (Binary State Speciation and Extinction)
-and its unresolved tree extensions, \"MuSSE\" (Multiple State Speciation and
-Extinction), \"QuaSSE\", \"GeoSSE\", and \"BiSSE-ness\" Other included methods
-include Markov models of discrete and continuous trait evolution and constant
-rate speciation and extinction.")
- (license license:gpl2+)))
-
(define-public sjcount
;; There is no tag for version 3.2, nor is there a release archive.
(let ((commit "292d3917cadb3f6834c81e509c30e61cd7ead6e5")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a3808e9882..f483178656 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24524,3 +24524,34 @@ discovery of differentially expressed genes and markers.")
estimation of phylogenetic trees and networks using Maximum Likelihood,
Maximum Parsimony, distance methods and Hadamard conjugation.")
(license license:gpl2+)))
+
+(define-public r-diversitree
+ (package
+ (name "r-diversitree")
+ (version "0.9-13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "diversitree" version))
+ (sha256
+ (base32
+ "00vi4klywi35hd170ksjv3xja3hqqbkcidcnrrlpgv4179k0azix"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (inputs `(("fftw" ,fftw) ("gsl" ,gsl)))
+ (propagated-inputs
+ `(("r-ape" ,r-ape)
+ ("r-desolve" ,r-desolve)
+ ("r-rcpp" ,r-rcpp)
+ ("r-subplex" ,r-subplex)))
+ (home-page "https://www.zoology.ubc.ca/prog/diversitree")
+ (synopsis "Comparative 'phylogenetic' analyses of diversification")
+ (description "This package contains a number of comparative \"phylogenetic\"
+methods, mostly focusing on analysing diversification and character evolution.
+Contains implementations of \"BiSSE\" (Binary State Speciation and Extinction)
+and its unresolved tree extensions, \"MuSSE\" (Multiple State Speciation and
+Extinction), \"QuaSSE\", \"GeoSSE\", and \"BiSSE-ness\" Other included methods
+include Markov models of discrete and continuous trait evolution and constant
+rate speciation and extinction.")
+ (license license:gpl2+)))