aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-28 16:57:43 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 11:24:46 +0200
commit6761090ca717583407c988ee2131f2c5e53b58af (patch)
treec4e282a72d6ed88758ac5bd518048fa62df9e983
parent04e6851aa8c6df08c9b1d7467195c3b6d7e03298 (diff)
downloadguix-6761090ca717583407c988ee2131f2c5e53b58af.tar
guix-6761090ca717583407c988ee2131f2c5e53b58af.tar.gz
gnu: Add r-forge.
* gnu/packages/cran.scm (r-forge): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 43397194fb..305f8e9756 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23558,3 +23558,26 @@ risk' table and 'censoring count plot'. Other functions are also available to
plot adjusted curves for Cox model and to visually examine Cox model
assumptions.")
(license license:gpl2)))
+
+(define-public r-forge
+ (package
+ (name "r-forge")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "forge" version))
+ (sha256
+ (base32
+ "0pjfzsc35agkh0zfw2czwajkbsyn6liys5irl5bhz5r1vim3jmwa"))))
+ (properties `((upstream-name . "forge")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-magrittr" ,r-magrittr)
+ ("r-rlang" ,r-rlang)))
+ (home-page "https://cran.r-project.org/web/packages/forge/")
+ (synopsis "Cast values into shape")
+ (description
+ "This package provides helper functions with a consistent interface to
+coerce and verify the types and shapes of values for input checking.")
+ (license license:asl2.0)))