aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-29 13:50:41 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 18:29:49 +0200
commit48d40c77178a0f69e2a7178b1e5d6ff6ac6ef095 (patch)
treedee4d8c480fe4a6da28f07f1e860cd21b2c95d35
parent35f033750f5f0d8b1a46887f595319dd393c2f6c (diff)
downloadguix-48d40c77178a0f69e2a7178b1e5d6ff6ac6ef095.tar
guix-48d40c77178a0f69e2a7178b1e5d6ff6ac6ef095.tar.gz
gnu: Add r-infer.
* gnu/packages/cran.scm (r-infer): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8ee609e412..089e3c527d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24089,3 +24089,33 @@ analysis using @code{dplyr}, @code{ggplot2}, and other Tidy tools.")
model without having to remember the different argument names across different
functions or computational engines (e.g. R, Spark, Stan, etc).")
(license license:gpl2)))
+
+(define-public r-infer
+ (package
+ (name "r-infer")
+ (version "0.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "infer" version))
+ (sha256
+ (base32
+ "0m00xhzrvmskwj4jwncakwxhzivn9pyiylq4r8s6ny4yiwqg303m"))))
+ (properties `((upstream-name . "infer")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-glue" ,r-glue)
+ ("r-magrittr" ,r-magrittr)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/tidymodels/infer")
+ (synopsis "Tidy statistical inference")
+ (description
+ "The objective of this package is to perform inference using an
+expressive statistical grammar that coheres with the Tidy design framework.")
+ (license license:cc0)))