aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-29 16:03:36 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 19:13:58 +0200
commit488001eb3f7938db6e079f6a4f6fedf96a9278c1 (patch)
tree7598b9c18b8666928cad9423a4c868ec6ed9e781
parent19748ea380268f4cba7cf8b8d9bf32daa99ac51c (diff)
downloadguix-488001eb3f7938db6e079f6a4f6fedf96a9278c1.tar
guix-488001eb3f7938db6e079f6a4f6fedf96a9278c1.tar.gz
gnu: Add r-icens.
* gnu/packages/bioconductor.scm (r-icens): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 73d5fe37eb..5fb360995c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2017, 2018, 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2020 Peter Lo <peterloleungyau@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8153,3 +8154,26 @@ user's input and automatically retrieving results from GREAT web server.")
simulation to eliminate overestimation of @code{K} and can reject the null
hypothesis @code{K=1}.")
(license license:agpl3+)))
+
+(define-public r-icens
+ (package
+ (name "r-icens")
+ (version "1.60.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Icens" version))
+ (sha256
+ (base32
+ "0fh7wgkrw20f61p06i87nccnbig9wv4m0jcg7cx1rw7g2ndnabgp"))))
+ (properties `((upstream-name . "Icens")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-survival" ,r-survival)))
+ (home-page "https://bioconductor.org/packages/Icens")
+ (synopsis "NPMLE for censored and truncated data")
+ (description
+ "This package provides many functions for computing the
+@dfn{nonparametric maximum likelihood estimator} (NPMLE) for censored and
+truncated data.")
+ (license license:artistic2.0)))