aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-11 20:08:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 21:59:21 +0200
commit415aa8a583a018ed2dd7e97a2045e7bd03a67674 (patch)
tree399c707d4b5029f07901ec353eef813cd4b832da
parentf9c0b2e05a22cc7a6667437c20bc2984e73835ae (diff)
downloadguix-415aa8a583a018ed2dd7e97a2045e7bd03a67674.tar
guix-415aa8a583a018ed2dd7e97a2045e7bd03a67674.tar.gz
gnu: r-phangorn: Move to (gnu packages cran).
* gnu/packages/bioinformatics.scm (r-phangorn): Move from here... * gnu/packages/cran.scm (r-phangorn): ...to here. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioinformatics.scm28
-rw-r--r--gnu/packages/cran.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a6505099fc..bec6c1dc4a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10936,34 +10936,6 @@ are optimized per data type and for subsetted calculations such that both
memory usage and processing time is minimized.")
(license license:expat)))
-(define-public r-phangorn
- (package
- (name "r-phangorn")
- (version "2.5.5")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "phangorn" version))
- (sha256
- (base32
- "0ihkaykqjmf80d8wrk3saphxvnv58zma6pd13633bd3cwanc33f5"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-ape" ,r-ape)
- ("r-fastmatch" ,r-fastmatch)
- ("r-igraph" ,r-igraph)
- ("r-magrittr" ,r-magrittr)
- ("r-matrix" ,r-matrix)
- ("r-quadprog" ,r-quadprog)
- ("r-rcpp" ,r-rcpp)))
- (home-page "https://github.com/KlausVigo/phangorn")
- (synopsis "Phylogenetic analysis in R")
- (description
- "Phangorn is a package for phylogenetic analysis in R. It supports
-estimation of phylogenetic trees and networks using Maximum Likelihood,
-Maximum Parsimony, distance methods and Hadamard conjugation.")
- (license license:gpl2+)))
-
(define-public r-dropbead
(let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
(revision "2"))
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 10d480a80c..a3808e9882 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24496,3 +24496,31 @@ dimensionality reduction; PCA, ICA, t-SNE, standard unsupervised clustering
algorithms; density clustering, hierarchical clustering, k-means, and the
discovery of differentially expressed genes and markers.")
(license license:gpl3)))
+
+(define-public r-phangorn
+ (package
+ (name "r-phangorn")
+ (version "2.5.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "phangorn" version))
+ (sha256
+ (base32
+ "0ihkaykqjmf80d8wrk3saphxvnv58zma6pd13633bd3cwanc33f5"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ape" ,r-ape)
+ ("r-fastmatch" ,r-fastmatch)
+ ("r-igraph" ,r-igraph)
+ ("r-magrittr" ,r-magrittr)
+ ("r-matrix" ,r-matrix)
+ ("r-quadprog" ,r-quadprog)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/KlausVigo/phangorn")
+ (synopsis "Phylogenetic analysis in R")
+ (description
+ "Phangorn is a package for phylogenetic analysis in R. It supports
+estimation of phylogenetic trees and networks using Maximum Likelihood,
+Maximum Parsimony, distance methods and Hadamard conjugation.")
+ (license license:gpl2+)))