aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-29 13:50:34 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 18:29:48 +0200
commit3dbe8a57ec4967f1719a5a3a4cecee7c863d420d (patch)
tree7642ac39f7f60553a005b7894d5c8d4e2271554e
parente309e17f84402377753f63a44616b252b88920ea (diff)
downloadguix-3dbe8a57ec4967f1719a5a3a4cecee7c863d420d.tar
guix-3dbe8a57ec4967f1719a5a3a4cecee7c863d420d.tar.gz
gnu: Add r-tidyposterior.
* gnu/packages/cran.scm (r-tidyposterior): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bdb114790e..3f61763f0e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23862,3 +23862,40 @@ and classes to be used in conjunction with other @code{tidymodels} packages
for finding reasonable values of hyper-parameters in models, pre-processing
methods, and post-processing steps.")
(license license:expat)))
+
+(define-public r-tidyposterior
+ (package
+ (name "r-tidyposterior")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidyposterior" version))
+ (sha256
+ (base32
+ "0wsv800w056ziqbnwal7ncmdy4li8cn5yrdx07w35b7j8kl4mwhg"))))
+ (properties `((upstream-name . "tidyposterior")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-generics" ,r-generics)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-lifecycle" ,r-lifecycle)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-rsample" ,r-rsample)
+ ("r-rstanarm" ,r-rstanarm)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)
+ ("r-vctrs" ,r-vctrs)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://tidyposterior.tidymodels.org")
+ (synopsis "Bayesian analysis to compare models using resampling statistics")
+ (description
+ "This package can be used to conduct post hoc analyses of resampling
+results generated by models. For example, if two models are evaluated with
+the @dfn{root mean squared error} (RMSE) using 10-fold cross-validation, there
+are 10 paired statistics. These can be used to make comparisons between
+models without involving a test set.")
+ (license license:gpl2)))