aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-29 13:50:38 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 18:29:49 +0200
commit39e6cac94760b0f0a8c1c4877ff3ada9f2600ca9 (patch)
tree2fcb1f5fe3c99ca652cdd3e22d856725bb9fca1b
parentf90b4b380af1278bfc47b3e70f0892b836a2ba8c (diff)
downloadguix-39e6cac94760b0f0a8c1c4877ff3ada9f2600ca9.tar
guix-39e6cac94760b0f0a8c1c4877ff3ada9f2600ca9.tar.gz
gnu: Add r-hunspell.
* gnu/packages/cran.scm (r-hunspell): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net> Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3d64763e0e..e7761158e2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23986,3 +23986,38 @@ documents, each with the same number of words. The tokenizers have a
consistent interface, and the package is built on the @code{stringi} and
@code{Rcpp} packages for fast yet correct tokenization in UTF-8 encoding.")
(license license:expat)))
+
+(define-public r-hunspell
+ (package
+ (name "r-hunspell")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "hunspell" version))
+ (sha256
+ (base32
+ "0mwqw5p0ph083plm2hr2hqr50bjg2dw862dpsfm4l2fgyy3rryq1"))))
+ (properties `((upstream-name . "hunspell")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)
+ ("r-rcpp" ,r-rcpp)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/ropensci/hunspell#readme")
+ (synopsis "High-performance stemmer, tokenizer, and spell checker")
+ (description
+ "This package provides a low-level spell checker and morphological
+analyzer based on the famous @code{hunspell} library. The package can analyze
+or check individual words as well as parse text, LaTeX, HTML or XML documents.
+For a more user-friendly interface use the @code{spelling} package which
+builds on this package to automate checking of files, documentation and
+vignettes in all common formats.")
+ ;; The hunspell library itself is available under one of GPL2, LGPL2.1, or
+ ;; MPL; in addition to these licenses the rest of the R wrapper is also
+ ;; available under the Expat license.
+ (license (list license:gpl2
+ license:lgpl2.1
+ license:mpl1.1
+ license:expat))))