aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-12 22:33:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-12 22:33:26 +0300
commit2c0b715389a723ecd35e9cc2694deb585a91ea76 (patch)
tree83306f495888a33f266b8b4af2a8a26837c382cd
parentfb24a4d5b87fa77a42966938df5e9761c0991876 (diff)
downloadguix-2c0b715389a723ecd35e9cc2694deb585a91ea76.tar
guix-2c0b715389a723ecd35e9cc2694deb585a91ea76.tar.gz
gnu: editorconfig-vim: Update to 1.1.1.
* gnu/packages/vim.scm (editorconfig-vim): Update to 1.1.1. [source]: Remove snippet. [arguments]: Remove custom 'patch-editorconfig-path phase. [inputs]: Remove editorconfig-core-c.
-rw-r--r--gnu/packages/vim.scm20
1 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 01ebda6cfe..083f9da3a4 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -570,7 +570,7 @@ are detected, the user is notified.")
(define-public editorconfig-vim
(package
(name "editorconfig-vim")
- (version "0.3.3")
+ (version "1.1.1")
(source
(origin
(method git-fetch)
@@ -580,27 +580,13 @@ are detected, the user is notified.")
(file-name (git-file-name name version))
(sha256
(base32
- "0vssfl1wjq0mv0p30c3dszwrh4yy90vwxmmdgqaxf5rykik7bdfd"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "plugin/editorconfig-core-py") #t))))
+ "0mp80bi2m56bb93szw87vy6q5s85yk9g91sl4pr51316rgdv5kkv"))))
(build-system copy-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-editorconfig-path
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((editorconfig (assoc-ref inputs "editorconfig-core")))
- (substitute* "plugin/editorconfig.vim"
- (("/opt") editorconfig))
- #t))))
- #:install-plan
+ '(#:install-plan
'(("autoload" "share/vim/vimfiles/")
("doc" "share/vim/vimfiles/")
("plugin" "share/vim/vimfiles/"))))
- (inputs
- `(("editorconfig-core" ,editorconfig-core-c)))
(home-page "https://editorconfig.org/")
(synopsis "EditorConfig plugin for Vim")
(description "EditorConfig makes it easy to maintain the correct coding