aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-05-06 23:58:22 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-14 23:46:07 +0200
commitf84ce99dccb61d417788f86bf4a7978d4716aa5c (patch)
treefe7e381278b9fe6801f4aa7643b93ea58217bf0c
parent46eac03e720e9b21d225e2ec1c41299c09202d18 (diff)
downloadguix-f84ce99dccb61d417788f86bf4a7978d4716aa5c.tar
guix-f84ce99dccb61d417788f86bf4a7978d4716aa5c.tar.gz
gnu: emacs-ledger-mode: Simplify build.
* gnu/packages/finance.scm (emacs-ledger-mode) [build-system]: Use emacs-build-system instead of cmake. [arguments]: Remove modules and imported-modules; move patch-path phase to after unpack so that the substitution actually causes a change; remove generate-autoload phase as that's built into the build system; remove patch-site-dir as that only affected cmake things; set #:exclude to '() so we install ledger-test.el. [native-inputs]: Remove emacs-minimal. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/finance.scm26
1 files changed, 5 insertions, 21 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index b8ec4a9dc0..3e03805fa7 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -400,22 +400,13 @@ in ability, and easy to use.")
(file-name (git-file-name name version))
(sha256
(base32 "1r5rcyxd6d1rqwamzpvqdbkbdf1zbj75aaciqijrklnm59ps244y"))))
- (build-system cmake-build-system)
+ (build-system emacs-build-system)
(arguments
- `(#:modules ((guix build cmake-build-system)
- (guix build utils)
- (guix build emacs-utils))
- #:imported-modules (,@%cmake-build-system-modules
- (guix build emacs-utils))
+ `(;; ledger-test.el is needed at runtime (but probably not for a good reason).
+ #:exclude '()
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-site-dir
- (lambda _
- (substitute* "CMakeLists.txt"
- (("DESTINATION share/emacs/site-lisp/ledger-mode")
- "DESTINATION share/emacs/site-lisp"))
- #t))
- (add-before 'build 'patch-path
+ (add-after 'unpack 'patch-path
(lambda* (#:key inputs #:allow-other-keys)
(let ((ledger (assoc-ref inputs "ledger")))
(make-file-writable "ledger-exec.el")
@@ -430,12 +421,6 @@ in ability, and easy to use.")
(invoke "makeinfo" "-o" target
"../source/doc/ledger-mode.texi"))
#t))
- (add-after 'install 'generate-autoload
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((site-dir (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp")))
- (emacs-generate-autoloads ,name site-dir))
- #t))
(replace 'check
(lambda _
(with-directory-excursion "../source/test"
@@ -443,8 +428,7 @@ in ability, and easy to use.")
(inputs
`(("ledger" ,ledger)))
(native-inputs
- `(("emacs-minimal" ,emacs-minimal)
- ("texinfo" ,texinfo)))
+ `(("texinfo" ,texinfo)))
(home-page "https://ledger-cli.org/")
(synopsis "Command-line double-entry accounting program")
(description