aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpineapples <guixuser6392@protonmail.com>2021-04-13 15:12:53 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-14 14:47:17 +0200
commite685ae63bb911fddaa671b618ee13ddae2bc4e71 (patch)
treedac21056818ee3c46d483e248a3d8f3edce06035
parentd456232712765c6fa7baf3de6b35431dfaab81b3 (diff)
downloadguix-e685ae63bb911fddaa671b618ee13ddae2bc4e71.tar
guix-e685ae63bb911fddaa671b618ee13ddae2bc4e71.tar.gz
gnu: Add seatd.
* gnu/packages/freedesktop.scm (seatd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/freedesktop.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7f8da7f3e4..e4ea951c41 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Anders Thuné <asse.97@gmail.com>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 pineapples <guixuser6392@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -828,6 +829,36 @@ GNOME Shell. The @command{localectl} command-line tool allows you to interact
with localed. This package is extracted from the broader systemd package.")
(license license:lgpl2.1+)))
+(define-public seatd
+ (package
+ (name "seatd")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~kennylevinsen/seatd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kglq8v4rnr3415mfaghyv2s2f8mxsy5s881gmm2908ig4n4j297"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags '("-Dlogind=enabled")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("elogind" ,elogind)))
+ (home-page "https://sr.ht/~kennylevinsen/seatd")
+ (synopsis "Seat management daemon and library")
+ (description
+ "This package provides a minimal seat management daemon whose task is to
+mediate access to shared devices, such as graphics and input, for applications
+that require it. It also provides a universal seat management library that
+allows applications to use whatever seat management is available.")
+ (license license:expat)))
+
(define-public packagekit
(package
(name "packagekit")