aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-14 14:29:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-14 17:03:43 +0200
commitbaca15bf6c0f41460547d4df1edb4d9500e5a7a3 (patch)
tree0ea5c11af0a18a47fb3b474e61383df98847fc54
parent6b851abb11f875c9ef862f48eba3cd3a8959c368 (diff)
downloadguix-baca15bf6c0f41460547d4df1edb4d9500e5a7a3.tar
guix-baca15bf6c0f41460547d4df1edb4d9500e5a7a3.tar.gz
gnu: Add rust-common-path-1.
* gnu/packages/crates-io.scm (rust-common-path-1): New variable.
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 09b2e81886..a5944dc3b2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7736,6 +7736,25 @@ combinator.")
and 1.0.")
(license (list license:expat license:asl2.0))))
+(define-public rust-common-path-1
+ (package
+ (name "rust-common-path")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "common-path" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "00firjly5xpb5hhmivnnhwakr1cwbqv8ckzyj0vbxczl89czg0i3"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page "https://gitlab.com/pwoolcoc/common-path")
+ (synopsis "Find the common prefix between a set of paths")
+ (description
+ "Common path finds the common prefix between a set of paths.")
+ (license (list license:expat license:asl2.0))))
+
;; This package requires features which are unavailable
;; on the stable releases of Rust.
(define-public rust-compiler-builtins-0.1