aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-17 15:44:56 -0500
committerLeo Famulari <leo@famulari.name>2019-02-19 14:34:31 -0500
commitc9b36f450b1c598174b03af19c35efc4bf1ee9e5 (patch)
treeccf537e3777b01029f0d28081755d1ed594e0475
parent951c7093a1b7907eea891f0454da53262375037d (diff)
downloadguix-c9b36f450b1c598174b03af19c35efc4bf1ee9e5.tar
guix-c9b36f450b1c598174b03af19c35efc4bf1ee9e5.tar.gz
gnu: Add magic-wormhole-mailbox-server.
* gnu/packages/magic-wormhole.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/magic-wormhole.scm65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index d9e6726e58..7aabf8dfd5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -297,6 +297,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/m4.scm \
%D%/packages/machine-learning.scm \
%D%/packages/man.scm \
+ %D%/packages/magic-wormhole.scm \
%D%/packages/mail.scm \
%D%/packages/make-bootstrap.scm \
%D%/packages/markup.scm \
diff --git a/gnu/packages/magic-wormhole.scm b/gnu/packages/magic-wormhole.scm
new file mode 100644
index 0000000000..b99ee7b113
--- /dev/null
+++ b/gnu/packages/magic-wormhole.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages magic-wormhole)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix build-system python)
+ #:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-xyz))
+
+(define-public magic-wormhole-mailbox-server
+ (package
+ (name "magic-wormhole-mailbox-server")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "magic-wormhole-mailbox-server" version))
+ (sha256
+ (base32
+ "1q6zhbx8fcpk7rchclm7yqcxdsc1x97hki2ji61sa544r5xvxv55"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ ;; This test requires network access.
+ (substitute* "src/wormhole_mailbox_server/test/test_web.py"
+ (("test_log_http") "disabled_test_log_http"))
+ #t)))))
+ (native-inputs
+ `(("python-mock" ,python-mock)))
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-autobahn" ,python-autobahn)
+ ("python-idna" ,python-idna)
+ ("python-service-identity" ,python-service-identity)
+ ("python-six" ,python-six)
+ ("python-treq" ,python-treq)
+ ("python-twisted" ,python-twisted)))
+ (home-page "https://github.com/warner/magic-wormhole-mailbox-server")
+ (synopsis "Magic-Wormhole central mailbox server")
+ (description "This package provides the main server that Magic-Wormhole
+clients connect to. The server performs store-and-forward delivery for small
+key-exchange and control messages. Bulk data is sent over a direct TCP
+connection, or through a transit-relay.")
+ (license expat)))