aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-17 13:18:41 -0500
committerLeo Famulari <leo@famulari.name>2019-02-19 14:34:30 -0500
commitb742c0065645837f9675ca16b1ad21da89544477 (patch)
tree9f6e867954621108585d59dda528ee56194eeb4f
parenta4fc80254a53b46b33f138d1009ddd044b8cb6be (diff)
downloadguix-b742c0065645837f9675ca16b1ad21da89544477.tar
guix-b742c0065645837f9675ca16b1ad21da89544477.tar.gz
gnu: Add python-humanize.
* gnu/packages/python-xyz.scm (python-humanize): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8a8ae5f284..c18b1e954b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
-;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Erik Edrosa <erik.edrosa@gmail.com>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -15039,3 +15039,24 @@ It features bit and byte granularity, easy debugging and testing, an
easy-to-extend subclass system, and lots of primitive constructs to
make your work easier.")
(license license:expat)))
+
+(define-public python-humanize
+ (package
+ (name "python-humanize")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "humanize" version))
+ (sha256
+ (base32
+ "06dvhm3k8lf2rayn1gxbd46y0fy1db26m3h9vrq7rb1ib08mfgx4"))))
+ (arguments
+ '(#:tests? #f)) ; tests not in pypi archive
+ (build-system python-build-system)
+ (home-page "https://github.com/jmoiron/humanize")
+ (synopsis "Print numerical information in a human-readable form")
+ (description "This package provides a Python module that displays numbers
+and dates in \"human readable\" forms. For example, it would display
+\"12345591313\" as \"12.3 billion\".")
+ (license license:expat)))