aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-17 14:59:59 -0500
committerLeo Famulari <leo@famulari.name>2019-02-19 14:34:31 -0500
commit951c7093a1b7907eea891f0454da53262375037d (patch)
tree478cdfc9d5abfcc59e458b5b181ddbd365c93375
parent215f3db0e3c91bbe13db5a73b50e998c03cfbe7c (diff)
downloadguix-951c7093a1b7907eea891f0454da53262375037d.tar
guix-951c7093a1b7907eea891f0454da53262375037d.tar.gz
gnu: Add python-autobahn.
* gnu/packages/python-web.scm (python-autobahn): New variable.
-rw-r--r--gnu/packages/python-web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ec7f43945e..839f48ce4f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages django)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
@@ -2999,3 +3000,32 @@ correct URLs for Python according to RFCs 3986 and 3987.")
@code{requests}} but written on top of Twisted's @code{Agents}. It offers a
high level API for making HTTP requests when using Twisted.")
(license license:expat)))
+
+(define-public python-autobahn
+ (package
+ (name "python-autobahn")
+ (version "19.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "autobahn" version))
+ (sha256
+ (base32
+ "1mm7j24ls01c7jb1ad5p5cpyxvzgydiyf8b04ihykh2v8g98j0x7"))))
+ (build-system python-build-system)
+ (arguments
+ ;; The tests fail to run:
+ ;; https://github.com/crossbario/autobahn-python/issues/1117
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-cffi" ,python-cffi)
+ ("python-twisted" ,python-twisted)
+ ("python-txaio" ,python-txaio)))
+ (home-page "https://crossbar.io/autobahn/")
+ (synopsis "Web Application Messaging Protocol implementation")
+ (description "This package provides an implementation of the @dfn{Web Application
+Messaging Protocol} (WAMP). WAMP connects components in distributed
+applications using Publish and Subscribe (PubSub) and routed Remote Procedure
+Calls (rRPC). It is ideal for distributed, multi-client and server applications
+such as IoT applications or multi-user database-driven business applications.")
+ (license license:expat)))