aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-19 07:33:54 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-19 09:54:37 +0100
commit89f2d7360b5ab62c07667b602c8bcac94c8a0aee (patch)
treed3bc258558553e9179b2da2ae98d15b801a4de62
parentfa75a21363d6dd07c1dbc990b88cd75f19454324 (diff)
downloadguix-89f2d7360b5ab62c07667b602c8bcac94c8a0aee.tar
guix-89f2d7360b5ab62c07667b602c8bcac94c8a0aee.tar.gz
gnu: workrave: Compute source COMMIT from VERSION.
* gnu/packages/gnome.scm (workrave)[version, source]: Conventionally generate COMMIT from VERSION, instead of the other way 'round.
-rw-r--r--gnu/packages/gnome.scm85
1 files changed, 41 insertions, 44 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a5ca245fe6..65f19c3ebc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7427,52 +7427,49 @@ configurable file renaming. ")
(license license:gpl3)))
(define-public workrave
- (let ((commit "v1_10_21"))
- (package
- (name "workrave")
- (version (string-map (match-lambda
- (#\_ #\.)
- (chr chr))
- (string-drop commit 1)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rcaelers/workrave.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "150qca8c552fakjlzkgarsxgp87l1xcwn19svqsa9d0cygqxjgia"))))
- (build-system glib-or-gtk-build-system)
- (propagated-inputs `(("glib" ,glib)
- ("gtk+" ,gtk+)
- ("gdk-pixbuf" ,gdk-pixbuf)
- ("gtkmm" ,gtkmm)
- ("glibmm" ,glibmm)
- ("libx11" ,libx11)
- ("libxtst" ,libxtst)
- ("dconf" ,dconf)
- ("libice" ,libice)))
- (inputs `(("libsm" ,libsm)
- ("python-cheetah" ,python2-cheetah)))
- (native-inputs `(("glib" ,glib "bin")
- ("pkg-config" ,pkg-config)
- ("gettext" ,gnu-gettext)
- ("autoconf" ,autoconf)
- ("autoconf-archive" , autoconf-archive)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("intltool" ,intltool)
- ("libxscrnsaver" ,libxscrnsaver)
- ("gobject-introspection" ,gobject-introspection)
- ("python2" ,python-2)))
- (synopsis "Tool to help prevent repetitive strain injury (RSI)")
- (description
- "Workrave is a program that assists in the recovery and prevention of
+ (package
+ (name "workrave")
+ (version "1.10.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rcaelers/workrave.git")
+ (commit (string-map (match-lambda (#\_ #\.) (chr chr)) version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "150qca8c552fakjlzkgarsxgp87l1xcwn19svqsa9d0cygqxjgia"))))
+ (build-system glib-or-gtk-build-system)
+ (propagated-inputs `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gtkmm" ,gtkmm)
+ ("glibmm" ,glibmm)
+ ("libx11" ,libx11)
+ ("libxtst" ,libxtst)
+ ("dconf" ,dconf)
+ ("libice" ,libice)))
+ (inputs `(("libsm" ,libsm)
+ ("python-cheetah" ,python2-cheetah)))
+ (native-inputs `(("glib" ,glib "bin")
+ ("pkg-config" ,pkg-config)
+ ("gettext" ,gnu-gettext)
+ ("autoconf" ,autoconf)
+ ("autoconf-archive" , autoconf-archive)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("intltool" ,intltool)
+ ("libxscrnsaver" ,libxscrnsaver)
+ ("gobject-introspection" ,gobject-introspection)
+ ("python2" ,python-2)))
+ (synopsis "Tool to help prevent repetitive strain injury (RSI)")
+ (description
+ "Workrave is a program that assists in the recovery and prevention of
repetitive strain injury (@dfn{RSI}). The program frequently alerts you to take
micro-pauses and rest breaks, and restricts you to your daily limit.")
- (home-page "http://www.workrave.org")
- (license license:gpl3+))))
+ (home-page "http://www.workrave.org")
+ (license license:gpl3+)))
(define-public ghex
(package